GHSA-wg4m-vvp6-2hc5low1.3
SilverStripe vulnerable to Cross-site Scripting
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (1) the CommenterURL parameter to PostCommentForm, and in the Forum module before 0.2.5 in SilverStripe before 2.3.5 allow remote attackers to inject arbitrary web script or HTML via (2) the Search parameter to forums/search (aka the search script).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/cms Packagist
Ecosystem versions
Earlier releases before 2.3.5
Fixed in 2.3.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}silverstripe/framework Packagist
Ecosystem versions
Earlier releases before 2.3.5
Fixed in 2.3.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2010-1593
- https://exchange.xforce.ibmcloud.com/vulnerabilities/55838
- https://exchange.xforce.ibmcloud.com/vulnerabilities/55839
- https://web.archive.org/web/20200228222759/https://www.securityfocus.com/bid/37923
- https://web.archive.org/web/20201208002434/http://www.securityfocus.com/archive/1/509139/100/0/threaded
- http://archives.neohapsis.com/archives/fulldisclosure/2010-01/0450.html
- http://groups.google.com/group/silverstripe-announce/browse_thread/thread/f51749342eee9456
- http://open.silverstripe.org/changeset/97074
- http://open.silverstripe.org/wiki/ChangeLog/2.3.5
- http://www.silverstripe.org/security-releases