Appwrite Directory Traversal vulnerability
The advisory, in context
The ACME-challenge endpoint in Appwrite 0.5.0 through 0.12.x before 0.12.2 allows remote attackers to read arbitrary local files via ../ directory traversal. In order to be vulnerable, APP_STORAGE_CERTIFICATES/.well-known/acme-challenge must exist on disk. (This pathname is automatically created if the user chooses to install Let's Encrypt certificates via Appwrite.)
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 0.5.0 before 0.12.2
Fixed in 0.12.2
26 explicitly affected versions
0.10.0, 0.10.1, 0.10.2, 0.10.3, 0.10.4, 0.11.0, 0.11.1, 0.11.2, 0.12.0, 0.12.1, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.9, 0.9.1, 0.9.2, 0.9.3, 0.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0.5.0"
},
{
"fixed": "0.12.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.10.0",
"0.10.1",
"0.10.2",
"0.10.3",
"0.10.4",
"0.11.0",
"0.11.1",
"0.11.2",
"0.12.0",
"0.12.1",
"0.5.0",
"0.5.1",
"0.5.2",
"0.5.3",
"0.6.0",
"0.6.1",
"0.6.2",
"0.7.0",
"0.7.1",
"0.7.2",
"0.8.0",
"0.9",
"0.9.1",
"0.9.2",
"0.9.3",
"0.9.4"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-25377
- https://github.com/appwrite/appwrite/pull/2780
- https://github.com/appwrite/appwrite/commit/892f6fa4ba0d44e2435ffad1a84542400cfb7a9b
- https://dubell.io/unauthenticated-lfi-in-appwrite-0.5.0-0.12.1
- https://github.com/appwrite/appwrite
- https://github.com/appwrite/appwrite/blob/0.12.0/app/controllers/general.php#L539
- https://github.com/appwrite/appwrite/releases/tag/0.12.2