GHSA-wcx3-63mm-h8x6medium6.1
MediaWiki UnlinkedWikibase Cross-site Scripting vulnerability
The advisory, in context
An issue was discovered in the UnlinkedWikibase extension in MediaWiki before 1.42.0. XSS can occur through an interface message. Error messages (in the $err var) are not escaped before being passed to Html::rawElement() in the getError() function in the Hooks class.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
samwilson/unlinked-wikibase Packagist
Ecosystem versions
Earlier releases before 1.42.0
Fixed in 1.42.0
1 explicitly affected versions
1.0.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.42.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2024-34500
- https://github.com/github/advisory-database/pull/5310
- https://gerrit.wikimedia.org/r/c/mediawiki/extensions/UnlinkedWikibase/+/1002175
- https://gerrit.wikimedia.org/r/mediawiki/extensions/UnlinkedWikibase.git
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/FU2FGUXXK6TMV6R52VRECLC6XCSQQISY
- https://phabricator.wikimedia.org/T357203