GHSA-w969-pq6x-267jmedium6.1
INTER-Mediator Cross-Site Scripting (XSS)
The advisory, in context
Multiple Cross-Site Scripting (XSS) issues were discovered in INTER-Mediator 5.5. The vulnerabilities exist due to insufficient filtration of user-supplied data (c and cred) passed to the "INTER-Mediator-master/Auth_Support/PasswordReset/resetpassword.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
inter-mediator/inter-mediator Packagist
Ecosystem versions
From 5.5 before 5.6
Fixed in 5.6
1 explicitly affected versions
5.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.5"
},
{
"fixed": "5.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.5"
]
}