GHSA-w8qg-j9fp-hrjfmedium6.8
phpMyAdmin Improper Input Validation
The advisory, in context
The checkHTTP function in libraries/Config.class.php in phpMyAdmin 4.5.x before 4.5.5.1 does not verify X.509 certificates from api.github.com SSL servers, which allows man-in-the-middle attackers to spoof these servers and obtain sensitive information via a crafted certificate.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpmyadmin/phpmyadmin Packagist
Ecosystem versions
From 4.5 before 4.5.5.1
Fixed in 4.5.5.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5"
},
{
"fixed": "4.5.5.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-2562
- https://github.com/phpmyadmin/phpmyadmin/commit/e42b7e3aedd29dd0f7a48575f20bfc5aca0ff976
- https://github.com/phpmyadmin/composer
- https://www.phpmyadmin.net/security/PMASA-2016-13
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178562.html
- http://lists.fedoraproject.org/pipermail/package-announce/2016-March/178869.html