GHSA-w7gh-f2fm-9q8rmedium5.4
PEAR HTTP_Request2 vulnerable to Cross-site Scripting
The advisory, in context
In PEAR HTTP_Request2 before 2.7.0, multiple files in the tests directory, notably tests/_network/getparameters.php and tests/_network/postparameters.php, reflect any GET or POST parameters, leading to XSS.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
pear/http_request2 Packagist
Ecosystem versions
Earlier releases before 2.7.0
Fixed in 2.7.0
9 explicitly affected versions
v2.2.0, v2.2.1, v2.3.0, v2.4.0, v2.4.1, v2.4.2, v2.5.0, v2.5.1, v2.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.2.0",
"v2.2.1",
"v2.3.0",
"v2.4.0",
"v2.4.1",
"v2.4.2",
"v2.5.0",
"v2.5.1",
"v2.6.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2025-43717
- https://github.com/pear/HTTP_Request2/commit/07925aa77e441dba0ff0fa973a09802729cb838f
- https://github.com/pear/HTTP_Request2/commit/265e05f9e08a28a38a57219516a8e4e2dfdbb147
- https://github.com/pear/HTTP_Request2
- https://github.com/pear/HTTP_Request2/blob/b1c61b71128045734d757c4d3d436457ace80ea7/package.xml#L24
- https://github.com/pear/HTTP_Request2/compare/v2.6.0...v2.7.0