MediaWiki Denial of Service vulnerability
The advisory, in context
An issue was discovered in ApiPageSet.php in MediaWiki before 1.35.12, 1.36.x through 1.39.x before 1.39.5, and 1.40.x before 1.40.1. It allows attackers to cause a denial of service (unbounded loop and RequestTimeoutException) when querying pages redirected to other variants with redirects and converttitles set.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 1.35.12
Fixed in 1.35.12
128 explicitly affected versions
1.20.3, 1.20.4, 1.20.5, 1.20.6, 1.20.7, 1.20.8, 1.21.0, 1.21.1, 1.21.10, 1.21.11, 1.21.2, 1.21.3, 1.21.4, 1.21.5, 1.21.6, 1.21.7, 1.21.8, 1.21.9, 1.22.0rc0, 1.24.0, 1.24.0-rc.0, 1.24.0-rc.1, 1.24.0-rc.2, 1.24.0-rc.3, 1.24.1, 1.24.2, 1.24.3, 1.24.4, 1.24.5, 1.24.6, 1.25.0, 1.25.0-rc.0, 1.25.1, 1.25.2, 1.25.3, 1.25.4, 1.25.5, 1.25.6, 1.26.0, 1.26.1, 1.26.2, 1.26.3, 1.26.4, 1.27.0, 1.27.0-rc.0, 1.27.0-rc.1, 1.27.1, 1.27.2, 1.27.3, 1.27.4, 1.27.5, 1.27.6, 1.27.7, 1.28.0, 1.28.0-rc.0, 1.28.0-rc.1, 1.28.1, 1.28.2, 1.28.3, 1.29.0, 1.29.0-rc.0, 1.29.0-rc.1, 1.29.1, 1.29.2, 1.29.3, 1.30.0, 1.30.0-rc.0, 1.30.1, 1.30.2, 1.31.0, 1.31.0-rc.0, 1.31.0-rc.1, 1.31.0-rc.2, 1.31.1, 1.31.10, 1.31.11, 1.31.12, 1.31.13, 1.31.14, 1.31.15, 1.31.16, 1.31.2, 1.31.3, 1.31.4, 1.31.5, 1.31.6, 1.31.7, 1.31.8, 1.31.9, 1.32.0, 1.32.0-rc.0, 1.32.0-rc.1, 1.32.0-rc.2, 1.32.1, 1.32.2, 1.32.3, 1.32.4, 1.32.5, 1.32.6, 1.33.0, 1.33.0-rc.0, 1.33.1, 1.33.2, 1.33.3, 1.33.4, 1.34.0, 1.34.0-rc.0, 1.34.0-rc.1, 1.34.1, 1.34.2, 1.34.3, 1.34.4, 1.35.0, 1.35.0-rc.0, 1.35.0-rc.1, 1.35.0-rc.2, 1.35.0-rc.3, 1.35.1, 1.35.10, 1.35.11, 1.35.2, 1.35.3, 1.35.4, 1.35.5, 1.35.6, 1.35.7, 1.35.8, 1.35.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.35.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.20.3",
"1.20.4",
"1.20.5",
"1.20.6",
"1.20.7",
"1.20.8",
"1.21.0",
"1.21.1",
"1.21.10",
"1.21.11",
"1.21.2",
"1.21.3",
"1.21.4",
"1.21.5",
"1.21.6",
"1.21.7",
"1.21.8",
"1.21.9",
"1.22.0rc0",
"1.24.0",
"1.24.0-rc.0",
"1.24.0-rc.1",
"1.24.0-rc.2",
"1.24.0-rc.3",
"1.24.1",
"1.24.2",
"1.24.3",
"1.24.4",
"1.24.5",
"1.24.6",
"1.25.0",
"1.25.0-rc.0",
"1.25.1",
"1.25.2",
"1.25.3",
"1.25.4",
"1.25.5",
"1.25.6",
"1.26.0",
"1.26.1",
"1.26.2",
"1.26.3",
"1.26.4",
"1.27.0",
"1.27.0-rc.0",
"1.27.0-rc.1",
"1.27.1",
"1.27.2",
"1.27.3",
"1.27.4",
"1.27.5",
"1.27.6",
"1.27.7",
"1.28.0",
"1.28.0-rc.0",
"1.28.0-rc.1",
"1.28.1",
"1.28.2",
"1.28.3",
"1.29.0",
"1.29.0-rc.0",
"1.29.0-rc.1",
"1.29.1",
"1.29.2",
"1.29.3",
"1.30.0",
"1.30.0-rc.0",
"1.30.1",
"1.30.2",
"1.31.0",
"1.31.0-rc.0",
"1.31.0-rc.1",
"1.31.0-rc.2",
"1.31.1",
"1.31.10",
"1.31.11",
"1.31.12",
"1.31.13",
"1.31.14",
"1.31.15",
"1.31.16",
"1.31.2",
"1.31.3",
"1.31.4",
"1.31.5",
"1.31.6",
"1.31.7",
"1.31.8",
"1.31.9",
"1.32.0",
"1.32.0-rc.0",
"1.32.0-rc.1",
"1.32.0-rc.2",
"1.32.1",
"1.32.2",
"1.32.3",
"1.32.4",
"1.32.5",
"1.32.6",
"1.33.0",
"1.33.0-rc.0",
"1.33.1",
"1.33.2",
"1.33.3",
"1.33.4",
"1.34.0",
"1.34.0-rc.0",
"1.34.0-rc.1",
"1.34.1",
"1.34.2",
"1.34.3",
"1.34.4",
"1.35.0",
"1.35.0-rc.0",
"1.35.0-rc.1",
"1.35.0-rc.2",
"1.35.0-rc.3",
"1.35.1",
"1.35.10",
"1.35.11",
"1.35.2",
"1.35.3",
"1.35.4",
"1.35.5",
"1.35.6",
"1.35.7",
"1.35.8",
"1.35.9"
]
}From 1.36.0 before 1.39.5
Fixed in 1.39.5
32 explicitly affected versions
1.36.0, 1.36.1, 1.36.2, 1.36.3, 1.36.4, 1.37.0, 1.37.0-rc.0, 1.37.0-rc.1, 1.37.0-rc.2, 1.37.1, 1.37.2, 1.37.3, 1.37.4, 1.37.5, 1.37.6, 1.38.0, 1.38.0-rc.0, 1.38.0-rc.1, 1.38.1, 1.38.2, 1.38.3, 1.38.4, 1.38.5, 1.38.6, 1.38.7, 1.39.0, 1.39.0-rc.0, 1.39.0-rc.1, 1.39.1, 1.39.2, 1.39.3, 1.39.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.36.0"
},
{
"fixed": "1.39.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.36.0",
"1.36.1",
"1.36.2",
"1.36.3",
"1.36.4",
"1.37.0",
"1.37.0-rc.0",
"1.37.0-rc.1",
"1.37.0-rc.2",
"1.37.1",
"1.37.2",
"1.37.3",
"1.37.4",
"1.37.5",
"1.37.6",
"1.38.0",
"1.38.0-rc.0",
"1.38.0-rc.1",
"1.38.1",
"1.38.2",
"1.38.3",
"1.38.4",
"1.38.5",
"1.38.6",
"1.38.7",
"1.39.0",
"1.39.0-rc.0",
"1.39.0-rc.1",
"1.39.1",
"1.39.2",
"1.39.3",
"1.39.4"
]
}From 1.40.0 before 1.40.1
Fixed in 1.40.1
1 explicitly affected versions
1.40.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.40.0"
},
{
"fixed": "1.40.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.40.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-45363
- https://github.com/wikimedia/mediawiki/commit/24c3ef2474c6daa20ed48168d46196a55346dfd8
- https://github.com/wikimedia/mediawiki
- https://lists.debian.org/debian-lts-announce/2023/11/msg00027.html
- https://phabricator.wikimedia.org/T333050
- https://www.debian.org/security/2023/dsa-5520