Improper Input Validation in Symfony
The advisory, in context
An issue was discovered in Symfony before 4.2.12 and 4.3.x before 4.3.8. The VarExport component incorrectly escapes strings, allowing some specially crafted ones to escalate to execution of arbitrary PHP code. This is related to symfony/var-exporter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.2.0 before 4.2.12
Fixed in 4.2.12
12 explicitly affected versions
v4.2.0, v4.2.1, v4.2.10, v4.2.11, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.2.0",
"v4.2.1",
"v4.2.10",
"v4.2.11",
"v4.2.2",
"v4.2.3",
"v4.2.4",
"v4.2.5",
"v4.2.6",
"v4.2.7",
"v4.2.8",
"v4.2.9"
]
}From 4.3.0 before 4.3.8
Fixed in 4.3.8
8 explicitly affected versions
v4.3.0, v4.3.1, v4.3.2, v4.3.3, v4.3.4, v4.3.5, v4.3.6, v4.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.3.0"
},
{
"fixed": "4.3.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.3.0",
"v4.3.1",
"v4.3.2",
"v4.3.3",
"v4.3.4",
"v4.3.5",
"v4.3.6",
"v4.3.7"
]
}From 4.2.0 before 4.2.12
Fixed in 4.2.12
12 explicitly affected versions
v4.2.0, v4.2.1, v4.2.10, v4.2.11, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.2.0",
"v4.2.1",
"v4.2.10",
"v4.2.11",
"v4.2.2",
"v4.2.3",
"v4.2.4",
"v4.2.5",
"v4.2.6",
"v4.2.7",
"v4.2.8",
"v4.2.9"
]
}From 4.3.0 before 4.3.8
Fixed in 4.3.8
8 explicitly affected versions
v4.3.0, v4.3.1, v4.3.2, v4.3.3, v4.3.4, v4.3.5, v4.3.6, v4.3.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.3.0"
},
{
"fixed": "4.3.8"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.3.0",
"v4.3.1",
"v4.3.2",
"v4.3.3",
"v4.3.4",
"v4.3.5",
"v4.3.6",
"v4.3.7"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2019-11325
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2019-11325.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/var-exporter/CVE-2019-11325.yaml
- https://github.com/symfony/symfony/releases/tag/v4.3.8
- https://github.com/symfony/var-exporter/compare/d8bf442...57e00f3
- https://symfony.com/blog/cve-2019-11325-fix-escaping-of-strings-in-varexporter
- https://symfony.com/blog/symfony-4-3-8-released
- https://symfony.com/cve-2019-11325