Auth0 PHP SDK has Insufficient Entropy in Cookie Encryption
The advisory, in context
Impact
In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies.
Am I Affected?
Consumers are affected if their application meets the following preconditions:
- Their application is using the Auth0-PHP SDK, versions between 8.0.0 and 8.18.0
- Their application is using the Auth0-PHP SDK, or the following SDKs that rely on the Auth0-PHP SDK:
- Auth0/symfony,
- Auth0/laravel0-auth0, or
- Auth0/wordpress
Resolution
Upgrade Auth0/Auth0-PHP to version 8.19.0 or greater.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 8.0.0 before 8.19.0
Fixed in 8.19.0
38 explicitly affected versions
8.0.0, 8.0.1, 8.0.2, 8.0.3, 8.0.4, 8.0.5, 8.0.6, 8.1.0, 8.10.0, 8.11.0, 8.11.1, 8.12.0, 8.13.0, 8.14.0, 8.15.0, 8.16.0, 8.17.0, 8.18.0, 8.2.0, 8.2.1, 8.3.0, 8.3.1, 8.3.2, 8.3.3, 8.3.4, 8.3.5, 8.3.6, 8.3.7, 8.3.8, 8.4.0, 8.5.0, 8.6.0, 8.7.0, 8.7.1, 8.8.0, 8.9.0, 8.9.1, 8.9.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.19.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.1",
"8.0.2",
"8.0.3",
"8.0.4",
"8.0.5",
"8.0.6",
"8.1.0",
"8.10.0",
"8.11.0",
"8.11.1",
"8.12.0",
"8.13.0",
"8.14.0",
"8.15.0",
"8.16.0",
"8.17.0",
"8.18.0",
"8.2.0",
"8.2.1",
"8.3.0",
"8.3.1",
"8.3.2",
"8.3.3",
"8.3.4",
"8.3.5",
"8.3.6",
"8.3.7",
"8.3.8",
"8.4.0",
"8.5.0",
"8.6.0",
"8.7.0",
"8.7.1",
"8.8.0",
"8.9.0",
"8.9.1",
"8.9.3"
]
}