GHSA-w2g4-g8xr-px4xmedium6.5
CSRF in PHP Server Monitor before 3.3.2
The advisory, in context
PHP Server Monitor before 3.3.2 has CSRF, as demonstrated by a Delete action.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpservermon/phpservermon Packagist
Ecosystem versions
Earlier releases before 3.3.2
Fixed in 3.3.2
8 explicitly affected versions
v3.1.0, v3.1.1, v3.2.0, v3.2.0-rc1, v3.2.1, v3.2.2, v3.3.0, v3.3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.1.0",
"v3.1.1",
"v3.2.0",
"v3.2.0-rc1",
"v3.2.1",
"v3.2.2",
"v3.3.0",
"v3.3.1"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2018-18921
- https://github.com/phpservermon/phpservermon/issues/670#issuecomment-440873239
- https://github.com/phpservermon/phpservermon/commit/30150714a8af0c82259b733f604fce54c0dcbf40
- https://medium.com/bugbountywriteup/cve-2018-18921-php-server-monitor-3-3-1-cross-site-request-forgery-a73e8dae563