MongoDB Driver may publish events containing authentication-related data
The advisory, in context
Some MongoDB Drivers may erroneously publish events containing authentication-related data to a command listener configured by an application. The published events may contain security-sensitive data when specific authentication-related commands are executed.
Without due care, an application may inadvertently expose this sensitive information, e.g., by writing it to a log file. This issue only arises if an application enables the command listener feature (this is not enabled by default).
This issue affects the MongoDB C Driver 1.0.0 prior to 1.17.7, MongoDB PHP Driver 1.0.0 prior to 1.9.2, MongoDB Swift Driver 1.0.0 prior to 1.1.1, MongoDB Node.js Driver 3.6 prior to 3.6.10, MongoDB Node.js Driver 4.0 prior to 4.17.0 and MongoDB Node.js Driver 5.0 prior to 5.8.0. This issue also affects users of the MongoDB C++ Driver dependent on the C driver 1.0.0 prior to 1.17.7 (C++ driver prior to 3.7.0).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.0.0 before 1.9.2
Fixed in 1.9.2
34 explicitly affected versions
1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1.0, 1.1.0-alpha1, 1.1.1, 1.1.2, 1.2.0, 1.2.0-alpha1, 1.3.0, 1.3.1, 1.3.2, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.5.1, 1.5.2, 1.6.0, 1.6.1, 1.7.0, 1.7.0-beta1, 1.7.0-beta2, 1.7.0-rc1, 1.7.1, 1.7.2, 1.8.0, 1.8.0-RC1, 1.9.0, 1.9.0-alpha1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.9.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.1.0",
"1.1.0-alpha1",
"1.1.1",
"1.1.2",
"1.2.0",
"1.2.0-alpha1",
"1.3.0",
"1.3.1",
"1.3.2",
"1.4.0",
"1.4.1",
"1.4.2",
"1.4.3",
"1.5.0",
"1.5.1",
"1.5.2",
"1.6.0",
"1.6.1",
"1.7.0",
"1.7.0-beta1",
"1.7.0-beta2",
"1.7.0-rc1",
"1.7.1",
"1.7.2",
"1.8.0",
"1.8.0-RC1",
"1.9.0",
"1.9.0-alpha1"
]
}From 3.6.0 before 3.6.10
Fixed in 3.6.10
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.6.0"
},
{
"fixed": "3.6.10"
}
],
"type": "SEMVER"
}
],
"versions": []
}From 4.0.0 before 4.17.0
Fixed in 4.17.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.17.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}From 5.0.0 before 5.8.0
Fixed in 5.8.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "5.0.0"
},
{
"fixed": "5.8.0"
}
],
"type": "SEMVER"
}
],
"versions": []
}From 1.0.0 before 1.1.1
Fixed in 1.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.1.1"
}
],
"type": "SEMVER"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2021-32050
- https://github.com/mongodb/mongo-php-driver/pull/1235
- https://github.com/mongodb/mongo-swift-driver/pull/643
- https://github.com/mongodb/mongo-php-driver/commit/4495de8313c0d313e4dde906fc7aedf998ee3748
- https://github.com/mongodb/node-mongodb-native/commit/8c8b4c3b8c55f10fb96f63d3bbfa5d408b4ed7d0
- https://jira.mongodb.org/browse/CDRIVER-3797
- https://jira.mongodb.org/browse/CXX-2028
- https://jira.mongodb.org/browse/NODE-3356
- https://jira.mongodb.org/browse/PHPC-1869
- https://jira.mongodb.org/browse/SWIFT-1229
- https://lists.debian.org/debian-lts-announce/2025/05/msg00027.html
- https://security.netapp.com/advisory/ntap-20231006-0001