GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-vxq6-8cwm-wj99medium5.5

LibreNMS allows stored XSS in Alert Template name field

Check your stack

The advisory, in context

Summary

A stored Cross-Site Scripting (XSS) vulnerability exists in LibreNMS (<= 25.6.0) in the Alert Template creation feature. This allows a user with the admin role to inject malicious JavaScript, which will be executed when the template is rendered, potentially compromising other admin accounts.


Details

In the LibreNMS web UI, when a user with the admin role visits /templates and clicks "Create new alert template", the "Template name" field fails to properly sanitize input. By inserting a payload like:

&lt;script>alert(document.cookie)&lt;/script> 

and filling the other fields with arbitrary content (e.g., test), once the template is saved, the script is executed. This confirms that user input is stored and later rendered without proper output encoding.

This vulnerability can be exploited for session hijacking, data theft, or other malicious actions targeting other admin users.


PoC

  1. Log in to LibreNMS using an account with the admin role.

  2. Navigate to: http://localhost:8000/templates.

  3. Click the "Create new alert template" button.

  4. Input the following into the Template name field:

    &lt;script>alert(document.cookie)&lt;/script>
    
  5. Fill the remaining fields (Template, Alert title, Recovery title) with arbitrary content such as test.

  6. Click "Create template".

  7. Upon saving, a JavaScript alert pops up, confirming the stored XSS is triggered. <img width="1574" height="848" alt="image" src="https://github.com/user-attachments/assets/bc482874-c47e-48e3-83b6-cb4a9dcf4a53" />


Impact

Type: Stored Cross-Site Scripting (XSS) Affected users: Only accounts with the admin role who access the Alert Templates page (http://localhost:8000/templates) are affected. Attackers need: Authenticated admin-level access.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 25.8.0

Fixed in 25.8.0

141 explicitly affected versions

1.19, 1.20, 1.20.1, 1.21, 1.22, 1.22.01, 1.23, 1.24, 1.25, 1.26, 1.27, 1.28, 1.29, 1.30, 1.30.01, 1.31, 1.31.01, 1.31.02, 1.31.03, 1.32, 1.32.01, 1.33, 1.33.01, 1.34, 1.35, 1.36, 1.36.01, 1.37, 1.38, 1.39, 1.40, 1.41, 1.42, 1.42.01, 1.43, 1.44, 1.45, 1.46, 1.47, 1.48, 1.48.1, 1.49, 1.50, 1.50.1, 1.51, 1.52, 1.53, 1.53.1, 1.54, 1.55, 1.56, 1.57, 1.58, 1.58.1, 1.59, 1.60, 1.61, 1.62, 1.62.1, 1.62.2, 1.63, 1.64, 1.64.1, 1.65, 1.65.1, 1.66, 1.67, 1.68, 1.69, 1.70.0, 1.70.1, 21.1.0, 21.10.0, 21.10.1, 21.10.2, 21.11.0, 21.12.0, 21.12.1, 21.2.0, 21.3.0, 21.4.0, 21.5.0, 21.5.1, 21.6.0, 21.7.0, 21.8.0, 21.9.0, 21.9.1, 22.1.0, 22.10.0, 22.11.0, 22.12.0, 22.2.0, 22.2.1, 22.2.2, 22.3.0, 22.4.0, 22.4.1, 22.5.0, 22.6.0, 22.7.0, 22.8.0, 22.9.0, 23.1.0, 23.1.1, 23.10.0, 23.11.0, 23.2.0, 23.4.0, 23.4.1, 23.5.0, 23.6.0, 23.7.0, 23.8.0, 23.8.1, 23.8.2, 23.9.0, 23.9.1, 24.1.0, 24.10.0, 24.10.1, 24.11.0, 24.12.0, 24.2.0, 24.3.0, 24.4.0, 24.4.1, 24.5.0, 24.6.0, 24.7.0, 24.8.0, 24.8.1, 24.9.0, 24.9.1, 25.1.0, 25.2.0, 25.3.0, 25.4.0, 25.5.0, 25.6.0, 25.7.0

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "25.8.0"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "1.19",
    "1.20",
    "1.20.1",
    "1.21",
    "1.22",
    "1.22.01",
    "1.23",
    "1.24",
    "1.25",
    "1.26",
    "1.27",
    "1.28",
    "1.29",
    "1.30",
    "1.30.01",
    "1.31",
    "1.31.01",
    "1.31.02",
    "1.31.03",
    "1.32",
    "1.32.01",
    "1.33",
    "1.33.01",
    "1.34",
    "1.35",
    "1.36",
    "1.36.01",
    "1.37",
    "1.38",
    "1.39",
    "1.40",
    "1.41",
    "1.42",
    "1.42.01",
    "1.43",
    "1.44",
    "1.45",
    "1.46",
    "1.47",
    "1.48",
    "1.48.1",
    "1.49",
    "1.50",
    "1.50.1",
    "1.51",
    "1.52",
    "1.53",
    "1.53.1",
    "1.54",
    "1.55",
    "1.56",
    "1.57",
    "1.58",
    "1.58.1",
    "1.59",
    "1.60",
    "1.61",
    "1.62",
    "1.62.1",
    "1.62.2",
    "1.63",
    "1.64",
    "1.64.1",
    "1.65",
    "1.65.1",
    "1.66",
    "1.67",
    "1.68",
    "1.69",
    "1.70.0",
    "1.70.1",
    "21.1.0",
    "21.10.0",
    "21.10.1",
    "21.10.2",
    "21.11.0",
    "21.12.0",
    "21.12.1",
    "21.2.0",
    "21.3.0",
    "21.4.0",
    "21.5.0",
    "21.5.1",
    "21.6.0",
    "21.7.0",
    "21.8.0",
    "21.9.0",
    "21.9.1",
    "22.1.0",
    "22.10.0",
    "22.11.0",
    "22.12.0",
    "22.2.0",
    "22.2.1",
    "22.2.2",
    "22.3.0",
    "22.4.0",
    "22.4.1",
    "22.5.0",
    "22.6.0",
    "22.7.0",
    "22.8.0",
    "22.9.0",
    "23.1.0",
    "23.1.1",
    "23.10.0",
    "23.11.0",
    "23.2.0",
    "23.4.0",
    "23.4.1",
    "23.5.0",
    "23.6.0",
    "23.7.0",
    "23.8.0",
    "23.8.1",
    "23.8.2",
    "23.9.0",
    "23.9.1",
    "24.1.0",
    "24.10.0",
    "24.10.1",
    "24.11.0",
    "24.12.0",
    "24.2.0",
    "24.3.0",
    "24.4.0",
    "24.4.1",
    "24.5.0",
    "24.6.0",
    "24.7.0",
    "24.8.0",
    "24.8.1",
    "24.9.0",
    "24.9.1",
    "25.1.0",
    "25.2.0",
    "25.3.0",
    "25.4.0",
    "25.5.0",
    "25.6.0",
    "25.7.0"
  ]
}

References