Improper Access Control in moodle
The advisory, in context
Users' enrollment capabilities were not being sufficiently checked in Moodle when they are restored into an existing course. This could lead to them unenrolling users without having permission to do so. Versions affected: 3.5 to 3.5.14, 3.7 to 3.7.8, 3.8 to 3.8.5, 3.9 to 3.9.2 and earlier unsupported versions. Fixed in 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.9.0 before 3.9.3
Fixed in 3.9.3
3 explicitly affected versions
v3.9.0, v3.9.1, v3.9.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.9.0"
},
{
"fixed": "3.9.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.9.0",
"v3.9.1",
"v3.9.2"
]
}From 3.8.0 before 3.8.6
Fixed in 3.8.6
6 explicitly affected versions
v3.8.0, v3.8.1, v3.8.2, v3.8.3, v3.8.4, v3.8.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.8.0"
},
{
"fixed": "3.8.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.8.0",
"v3.8.1",
"v3.8.2",
"v3.8.3",
"v3.8.4",
"v3.8.5"
]
}From 3.7.0 before 3.7.9
Fixed in 3.7.9
9 explicitly affected versions
v3.7.0, v3.7.1, v3.7.2, v3.7.3, v3.7.4, v3.7.5, v3.7.6, v3.7.7, v3.7.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.7.0"
},
{
"fixed": "3.7.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.7.0",
"v3.7.1",
"v3.7.2",
"v3.7.3",
"v3.7.4",
"v3.7.5",
"v3.7.6",
"v3.7.7",
"v3.7.8"
]
}From 3.5 before 3.5.15
Fixed in 3.5.15
17 explicitly affected versions
v3.5.0, v3.5.0-beta, v3.5.0-rc1, v3.5.1, v3.5.10, v3.5.11, v3.5.12, v3.5.13, v3.5.14, v3.5.2, v3.5.3, v3.5.4, v3.5.5, v3.5.6, v3.5.7, v3.5.8, v3.5.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.5"
},
{
"fixed": "3.5.15"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.5.0",
"v3.5.0-beta",
"v3.5.0-rc1",
"v3.5.1",
"v3.5.10",
"v3.5.11",
"v3.5.12",
"v3.5.13",
"v3.5.14",
"v3.5.2",
"v3.5.3",
"v3.5.4",
"v3.5.5",
"v3.5.6",
"v3.5.7",
"v3.5.8",
"v3.5.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-25698
- https://github.com/moodle/moodle/commit/c8ac07fb50fa92eee1d574823fbda09e1b309a63
- https://bugzilla.redhat.com/show_bug.cgi?id=1895419
- https://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-67837
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4NNFCHPPHRJNJROIX6SYMHOC6HMKP3GU
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/B55KXBVAT45MDASJ3EK6VIGQOYGJ4NH6
- https://moodle.org/mod/forum/discuss.php?d=413935