GHSA-vwfx-hh3w-fj99medium4.6
Potential XSS injection in the newsletter conditions field
The advisory, in context
Impact
An employee can inject javascript in the newsletter condition field that will then be executed on the front office
Patches
The issue has been fixed in 2.6.1
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
prestashop/ps_emailsubscription Packagist
Ecosystem versions
Earlier releases before 2.6.1
Fixed in 2.6.1
10 explicitly affected versions
v1.0.1, v1.1.0, v1.1.1, v1.1.2, v1.1.6, v2.1.0, v2.2.0, v2.3.0, v2.5.0, v2.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.6.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.0.1",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.1.6",
"v2.1.0",
"v2.2.0",
"v2.3.0",
"v2.5.0",
"v2.6.0"
]
}References
- https://github.com/PrestaShop/ps_emailsubscription/security/advisories/GHSA-vwfx-hh3w-fj99
- https://nvd.nist.gov/vuln/detail/CVE-2021-21418
- https://github.com/PrestaShop/ps_emailsubscription/commit/664ffb225e2afb4a32640bbedad667dc6e660b70
- https://github.com/PrestaShop/ps_emailsubscription/releases/tag/v2.6.1
- https://packagist.org/packages/prestashop/ps_emailsubscription