GHSA-vrf6-q7qj-69v5low
Moodle allows attackers to upload files containing JavaScript
The advisory, in context
webservice/upload.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not ensure that a file upload is for a private or draft area, which allows remote authenticated users to upload files containing JavaScript, and consequently conduct cross-site scripting (XSS) attacks, by specifying the profile-picture area.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 2.6.0 before 2.6.6
Fixed in 2.6.6
6 explicitly affected versions
v2.6.0, v2.6.1, v2.6.2, v2.6.3, v2.6.4, v2.6.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.6.0"
},
{
"fixed": "2.6.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.6.0",
"v2.6.1",
"v2.6.2",
"v2.6.3",
"v2.6.4",
"v2.6.5"
]
}moodle/moodle Packagist
Ecosystem versions
From 2.7.0 before 2.7.3
Fixed in 2.7.3
3 explicitly affected versions
v2.7.0, v2.7.1, v2.7.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.7.0"
},
{
"fixed": "2.7.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.7.0",
"v2.7.1",
"v2.7.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2014-7835
- https://github.com/moodle/moodle/commit/2f87351d5480f562d6811cdf3bea032612e0325e
- https://github.com/moodle/moodle/commit/76ae1f6068f63149acc2d8c362af94067f4a227d
- https://github.com/moodle/moodle/commit/ea1fbc00285514242d620ea017e187eb139deedb
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=275161
- https://web.archive.org/web/20150914064838/http://www.securitytracker.com/id/1031215
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-47868
- http://openwall.com/lists/oss-security/2014/11/17/11