GHSA-vq4j-qcx7-ppc6medium6.1
Thelia Cross-site Scripting vulnerability in BackOffice
No CVE assignedCheck your stack
The advisory, in context
The BackOffice of Thelia (error.html template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
thelia/thelia Packagist
Ecosystem versions
From 2.1.0 before 2.1.2
Fixed in 2.1.2
2 explicitly affected versions
2.1.0, 2.1.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"2.1.0",
"2.1.1"
]
}References
- https://github.com/thelia/thelia/commit/e7c9c3be1d580067cba102f1f9530baf067c1e5d
- https://github.com/FriendsOfPHP/security-advisories/blob/master/thelia/thelia/2015-02-24-1.yaml
- https://github.com/thelia/thelia
- https://web.archive.org/web/20160406004324/http://thelia.net/version-2-1-2-with-security-fix