Clickstorm SEO Allows Cross-Site Scripting (XSS)
The advisory, in context
A cross-site scripting (XSS) vulnerability has been discovered in the Clickstorm SEO extension. This vulnerabily is exploitable by a logged in backend user utilizing the TYPO3 backend user interface. This user can create output in the HTML context by exploiting improperly encoded user input. Updates 6.7.0, 7.4.0, 8.3.0 and 9.2.0 are available for download.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 9.0.0 before 9.2.0
Fixed in 9.2.0
3 explicitly affected versions
9.0.0, 9.0.1, 9.1.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.2.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"9.0.0",
"9.0.1",
"9.1.0"
]
}From 8.0.0 before 8.3.0
Fixed in 8.3.0
7 explicitly affected versions
8.0.0, 8.0.1, 8.1.0, 8.1.1, 8.1.2, 8.2.0, 8.2.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.3.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"8.0.0",
"8.0.1",
"8.1.0",
"8.1.1",
"8.1.2",
"8.2.0",
"8.2.1"
]
}From 7.0.0 before 7.4.0
Fixed in 7.4.0
9 explicitly affected versions
7.0.0, 7.0.1, 7.1.0, 7.2.0, 7.2.1, 7.3.0, 7.3.1, 7.3.2, 7.3.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "7.0.0"
},
{
"fixed": "7.4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"7.0.0",
"7.0.1",
"7.1.0",
"7.2.0",
"7.2.1",
"7.3.0",
"7.3.1",
"7.3.2",
"7.3.3"
]
}From 6.0.0 before 6.7.0
Fixed in 6.7.0
12 explicitly affected versions
6.0.0, 6.1.0, 6.1.1, 6.2.0, 6.2.1, 6.3.0, 6.3.1, 6.3.2, 6.4.0, 6.4.1, 6.5.0, 6.6.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"6.0.0",
"6.1.0",
"6.1.1",
"6.2.0",
"6.2.1",
"6.3.0",
"6.3.1",
"6.3.2",
"6.4.0",
"6.4.1",
"6.5.0",
"6.6.0"
]
}