Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor
The advisory, in context
lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 2.3.10
Fixed in 2.3.10
6 explicitly affected versions
v2.3.4, v2.3.5, v2.3.6, v2.3.7, v2.3.8, v2.3.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.3.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.3.4",
"v2.3.5",
"v2.3.6",
"v2.3.7",
"v2.3.8",
"v2.3.9"
]
}From 2.4.0-beta before 2.4.7
Fixed in 2.4.7
8 explicitly affected versions
v2.4.0, v2.4.0-rc1, v2.4.1, v2.4.2, v2.4.3, v2.4.4, v2.4.5, v2.4.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4.0-beta"
},
{
"fixed": "2.4.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.4.0",
"v2.4.0-rc1",
"v2.4.1",
"v2.4.2",
"v2.4.3",
"v2.4.4",
"v2.4.5",
"v2.4.6"
]
}From 2.5.0-beta before 2.5.3
Fixed in 2.5.3
5 explicitly affected versions
v2.5.0, v2.5.0-beta, v2.5.0-rc1, v2.5.1, v2.5.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.5.0-beta"
},
{
"fixed": "2.5.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.5.0",
"v2.5.0-beta",
"v2.5.0-rc1",
"v2.5.1",
"v2.5.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2013-4522
- https://github.com/moodle/moodle/commit/d0041fb110201d3dc1a4546eca8b6108b440d1c5
- https://github.com/moodle/moodle
- https://moodle.org/mod/forum/discuss.php?d=244479
- http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-38743
- http://openwall.com/lists/oss-security/2013/11/25/1