GHSA-vm4p-gh82-xq96medium6.1
Cross-site Scripting in Admidio
The advisory, in context
Admidio v4.2.12 and below is vulnerable to Cross Site Scripting (XSS).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
admidio/admidio Packagist
Ecosystem versions
Earlier releases before 4.2.13
Fixed in 4.2.13
18 explicitly affected versions
4.1.0, 4.1.3, v4.2-Beta.1, v4.2-Beta.2, v4.2-Beta.3, v4.2.0, v4.2.1, v4.2.10, v4.2.11, v4.2.12, v4.2.2, v4.2.3, v4.2.4, v4.2.5, v4.2.6, v4.2.7, v4.2.8, v4.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.2.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.1.0",
"4.1.3",
"v4.2-Beta.1",
"v4.2-Beta.2",
"v4.2-Beta.3",
"v4.2.0",
"v4.2.1",
"v4.2.10",
"v4.2.11",
"v4.2.12",
"v4.2.2",
"v4.2.3",
"v4.2.4",
"v4.2.5",
"v4.2.6",
"v4.2.7",
"v4.2.8",
"v4.2.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2023-47380
- https://github.com/Admidio/admidio
- https://github.com/Admidio/admidio/releases/tag/v4.2.13
- https://www.admidio.org/intern/adm_program/modules/announcements/announcements.php?ann_uuid=714ead2b-1718-4251-a9a3-f1b0df12d60e&headline=Blog
- https://www.getastra.com/blog/security-audit/reflected-xss-vulnerability-in-admidio