GHSA-vm37-j55j-8655high7.8
OS Command Injection in Microweber
The advisory, in context
Microweber is a content management system with drag and drop. Prior to version 1.2.11, Microweber is vulnerable to OS Command Injection.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
microweber/microweber Packagist
Ecosystem versions
Earlier releases before 1.2.11
Fixed in 1.2.11
19 explicitly affected versions
0.9.346, 0.93, 0.931, 0.934, 0.951, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.1, v1.2.10, v1.2.3, v1.2.4, v1.2.5, v1.2.6, v1.2.7, v1.2.8, v1.2.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.9.346",
"0.93",
"0.931",
"0.934",
"0.951",
"1.0.3",
"1.0.4",
"1.0.5",
"1.0.6",
"1.0.7",
"1.1",
"v1.2.10",
"v1.2.3",
"v1.2.4",
"v1.2.5",
"v1.2.6",
"v1.2.7",
"v1.2.8",
"v1.2.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-0557
- https://github.com/microweber/microweber/commit/0a7e5f1d81de884861ca677ee1aaac31f188d632
- https://github.com/microweber/microweber
- https://huntr.dev/bounties/660c89af-2de5-41bc-aada-9e4e78142db8
- https://www.exploit-db.com/exploits/50768
- http://packetstormsecurity.com/files/166077/Microweber-1.2.11-Shell-Upload.html