The disqualify lead action may be executed without CSRF token check
The advisory, in context
Summary
The attacker is able to disqualify any Lead with a Cross-Site Request Forgery (CSRF) attack.
Workarounds
There are no workarounds that address this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.1.0 before 4.1.17
Fixed in 4.1.17
39 explicitly affected versions
3.1.0, 3.1.1, 3.1.10, 3.1.11, 3.1.12, 3.1.13, 3.1.14, 3.1.15, 3.1.16, 3.1.17, 3.1.2, 3.1.3, 3.1.4, 3.1.5, 3.1.6, 3.1.7, 3.1.8, 3.1.9, 4.0.0, 4.0.0-beta, 4.0.0-rc, 4.1.0, 4.1.0-beta, 4.1.0-rc, 4.1.0-rc4, 4.1.1, 4.1.1-rc, 4.1.10, 4.1.11, 4.1.12, 4.1.13, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.1.6, 4.1.7, 4.1.8, 4.1.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1.0"
},
{
"fixed": "4.1.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.1.0",
"3.1.1",
"3.1.10",
"3.1.11",
"3.1.12",
"3.1.13",
"3.1.14",
"3.1.15",
"3.1.16",
"3.1.17",
"3.1.2",
"3.1.3",
"3.1.4",
"3.1.5",
"3.1.6",
"3.1.7",
"3.1.8",
"3.1.9",
"4.0.0",
"4.0.0-beta",
"4.0.0-rc",
"4.1.0",
"4.1.0-beta",
"4.1.0-rc",
"4.1.0-rc4",
"4.1.1",
"4.1.1-rc",
"4.1.10",
"4.1.11",
"4.1.12",
"4.1.13",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.1.6",
"4.1.7",
"4.1.8",
"4.1.9"
]
}From 4.2.0 before 4.2.7
Fixed in 4.2.7
7 explicitly affected versions
4.2.0, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.2.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.2.0"
},
{
"fixed": "4.2.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.2.0",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.2.6"
]
}