GHSA-vf23-f26f-mjj9critical9.8
Access of Resource Using Incompatible Type ('Type Confusion') in yourls/yourls
The advisory, in context
Impact
YOURLS through 1.7.3 is affected by a type juggling vulnerability in the API component that can result in login bypass.
Patches
https://github.com/YOURLS/YOURLS/releases/tag/1.7.4 https://github.com/YOURLS/YOURLS/pull/2542
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-14537
- https://github.com/Wocanilo/CVE-2019-14537
For more information
If you have any questions or comments about this advisory:
- Open an issue in YOURLS repository
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yourls/yourls Packagist
Ecosystem versions
Earlier releases before 1.7.4
Fixed in 1.7.4
3 explicitly affected versions
1.7.1, 1.7.2, 1.7.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.7.1",
"1.7.2",
"1.7.3"
]
}References
- https://github.com/YOURLS/YOURLS/security/advisories/GHSA-vf23-f26f-mjj9
- https://nvd.nist.gov/vuln/detail/CVE-2019-14537
- https://github.com/YOURLS/YOURLS/pull/2542
- https://github.com/Wocanilo/CVE-2019-14537
- https://github.com/YOURLS/YOURLS
- https://github.com/YOURLS/YOURLS/commits/master
- https://github.com/YOURLS/YOURLS/releases
- https://github.com/advisories/GHSA-vf23-f26f-mjj9
- https://security-garage.com/index.php/cves/cve-2019-14537-api-authentication-bypass-via-type-juggling