GHSA-vc5r-xfc4-4x22medium4.8
Cross-site Scripting in Pimcore Datahub
The advisory, in context
Pimcore Datahub prior to 1.2.4 is vulnerable to stored cross-site scripting. An admin user accessing Datahub triggers the attack, which may result in the user's cookie being stolen.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
pimcore/data-hub Packagist
Ecosystem versions
Earlier releases before 1.2.4
Fixed in 1.2.4
34 explicitly affected versions
v0.1, v0.2, v0.3, v0.4, v0.5, v0.6, v0.6.1, v0.6.2, v0.6.3, v0.7, v0.8, v1.0, v1.0.1, v1.0.10, v1.0.11, v1.0.2, v1.0.3, v1.0.4, v1.0.5, v1.0.6, v1.0.7, v1.0.8, v1.0.9, v1.1.0, v1.1.1, v1.1.2, v1.1.3, v1.1.4, v1.1.6, v1.1.7, v1.2.0, v1.2.1, v1.2.2, v1.2.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.2.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1",
"v0.2",
"v0.3",
"v0.4",
"v0.5",
"v0.6",
"v0.6.1",
"v0.6.2",
"v0.6.3",
"v0.7",
"v0.8",
"v1.0",
"v1.0.1",
"v1.0.10",
"v1.0.11",
"v1.0.2",
"v1.0.3",
"v1.0.4",
"v1.0.5",
"v1.0.6",
"v1.0.7",
"v1.0.8",
"v1.0.9",
"v1.1.0",
"v1.1.1",
"v1.1.2",
"v1.1.3",
"v1.1.4",
"v1.1.6",
"v1.1.7",
"v1.2.0",
"v1.2.1",
"v1.2.2",
"v1.2.3"
]
}