GHSA-vc4f-2g7f-pmqrmedium5.4
MunkiReport Cross-Site Scripting (XSS) Filter Bypass On Comment
The advisory, in context
A Cross-Site Scripting (XSS) vulnerability in the comment module before 4.0 for MunkiReport allows remote attackers to inject arbitrary web script or HTML by posting a new comment.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
munkireport/comment Packagist
Ecosystem versions
Earlier releases before 4.0
Fixed in 4.0
7 explicitly affected versions
v1.1, v2.0, v2.1, v2.2, v3.0, v3.1, v3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "4.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.1",
"v2.0",
"v2.1",
"v2.2",
"v3.0",
"v3.1",
"v3.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-15885
- https://github.com/munkireport/comment/commit/ee4c1cd28fdcb42eb24c0cfea24ddf02478f9869
- https://github.com/munkireport/comment
- https://github.com/munkireport/comment/releases
- https://github.com/munkireport/munkireport-php
- https://github.com/munkireport/munkireport-php/releases/tag/v5.6.3
- https://github.com/munkireport/munkireport-php/wiki/20200722--XSS-Filter-Bypass-On-Comments