TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
Impact
Stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option.
Source excerpt · OSVWhat to do
Upgrade to TinyMCE 7.9.3 or higher.
Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
| Affected range | Recorded fix |
|---|---|
| Earlier releases through 5.10.9 (inclusive)Semantic versions | Not recorded |
| From 6.0.0 before 7.9.3Semantic versions | 7.9.3 |
| From 8.0.0 before 8.5.1Semantic versions | 8.5.1 |
Version evidence: OSV · GHSA-v98h-vmpc-fpqv
View original version evidence (0 explicit versions)
| Affected range | Recorded fix |
|---|---|
| Earlier releases through 5.10.9 (inclusive)Ecosystem versions | Not recorded |
| From 6.0.0 before 7.9.3Ecosystem versions | 7.9.3 |
| From 8.0.0 before 8.5.1Ecosystem versions | 8.5.1 |
Version evidence: OSV · GHSA-v98h-vmpc-fpqv
View original version evidence (245 explicit versions)
| Affected range | Recorded fix |
|---|---|
| Earlier releases through 5.10.9 (inclusive)Ecosystem versions | Not recorded |
| From 6.0.0 before 7.9.3Ecosystem versions | 7.9.3 |
| From 8.0.0 before 8.5.1Ecosystem versions | 8.5.1 |
Version evidence: OSV · GHSA-v98h-vmpc-fpqv
View original version evidence (238 explicit versions)
Original source description
Impact
Stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option.
Patches
Patched by validating decoded mce:protected content against configured protect regex rules before restoring. Users should upgrade to the latest patched version.
Workarounds
No official workaround available.
Fix
To avoid this vulnerability:
Upgrade to TinyMCE 8.5.1 or higher. Upgrade to TinyMCE 7.9.3 or higher. Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract).
Acknowledgements
Tiny thanks Ivan Babenko for their help identifying this vulnerability.
References
- Security advisory github.com/tinymce/tinymce/security/advisories/GHSA-v98h-vmpc-fpqv
- Security advisory nvd.nist.gov/vuln/detail/CVE-2026-47762
- Source reference github.com/tinymce/tinymce
- Release notes www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/
- Release notes www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/