GHSA-v7qf-22rw-chphmedium4.8
MantisBT XSS via adm_config_report.php's action parameter
Impact
A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code through a crafted 'action' parameter. This is fixed in 1.3.8, 2.1.2, and 2.2.2.
Source excerpt · OSVAffected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mantisbt/mantisbt Packagist
| Affected range | Recorded fix |
|---|---|
| Earlier releases before 1.3.8Ecosystem versions | 1.3.8 |
| From 2.0.0 before 2.1.2Ecosystem versions | 2.1.2 |
| From 2.2.0 before 2.2.2Ecosystem versions | 2.2.2 |
Version evidence: OSV · GHSA-v7qf-22rw-chph
View original version evidence (0 explicit versions)
Original source description
A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page (adm_config_report.php) allows remote attackers to inject arbitrary code through a crafted 'action' parameter. This is fixed in 1.3.8, 2.1.2, and 2.2.2.
References
- Security advisory nvd.nist.gov/vuln/detail/CVE-2017-6973
- Patch github.com/mantisbt/mantisbt/commit/034cd07b47af37366fc7b726cb4a4f971d3d3fb9
- Patch github.com/mantisbt/mantisbt/commit/15e52e84c389afe8b03ed3cdb59b6549257ed197
- Patch github.com/mantisbt/mantisbt/commit/da74c5aa02bcf21cfaab1180f892c22415e5fea6
- Source reference github.com/mantisbt/mantisbt
- Source reference www.mantisbt.org/bugs/view.php