GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-v7cf-8gh9-gxmjhigh8.1

Winter: Stored XSS through Brand Settings custom styles

Check your stack

The advisory, in context

Impact

Users with the backend.manage_branding ("Customize the back-end") permission can provide custom CSS through Settings → Customize Backend → Styles that is compiled through the LESS CSS parser and rendered on every backend page. Previously, the compiled output was not sanitized, which could have allowed a stored XSS attack.

Although this is a valid security issue, it's important to note that its severity is relatively low. To exploit the vulnerability, an attacker would already need to have trusted access to the Winter CMS backend with a specific administrative permission. The Winter CMS maintainers recommend that the backend.manage_branding permission only be granted to trusted administrators and developers.

A related issue exists in the custom styles field at Settings → Editor Settings → Markup Styles (backend.manage_editor permission), which uses the same rendering mechanism and is addressed separately.

All users are advised to update to the latest version to ensure their systems remain secure.

Patches

This issue has been patched in v1.2.13.

Workarounds

Apply https://github.com/wintercms/winter/commit/d28f0b9474af79cfaa80eeb9d691f7a7c4469720 manually if unable to upgrade to v1.2.13.

Resources

  • CVE-2025-61676 (identical vulnerability in October CMS, patched in v3.7.13 and v4.0.12)

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

Earlier releases before 1.2.13

Fixed in 1.2.13

26 explicitly affected versions

v1.0.473, v1.0.474, v1.0.475, v1.1.10, v1.1.11, v1.1.2, v1.1.3, v1.1.4, v1.1.5, v1.1.6, v1.1.7, v1.1.8, v1.1.9, v1.2.0, v1.2.1, v1.2.10, v1.2.11, v1.2.12, v1.2.2, v1.2.3, v1.2.4, v1.2.5, v1.2.6, v1.2.7, v1.2.8, v1.2.9

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "0"
        },
        {
          "fixed": "1.2.13"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.0.473",
    "v1.0.474",
    "v1.0.475",
    "v1.1.10",
    "v1.1.11",
    "v1.1.2",
    "v1.1.3",
    "v1.1.4",
    "v1.1.5",
    "v1.1.6",
    "v1.1.7",
    "v1.1.8",
    "v1.1.9",
    "v1.2.0",
    "v1.2.1",
    "v1.2.10",
    "v1.2.11",
    "v1.2.12",
    "v1.2.2",
    "v1.2.3",
    "v1.2.4",
    "v1.2.5",
    "v1.2.6",
    "v1.2.7",
    "v1.2.8",
    "v1.2.9"
  ]
}

References