GHSA-v69f-5jxm-hwvvcritical9.3
Volt Allows RCE Via User-Crafted Requests
The advisory, in context
Malicious, user-crafted request payloads could potentially lead to remote code execution within Volt components.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
livewire/volt Packagist
Ecosystem versions
Earlier releases before 1.7.0
Fixed in 1.7.0
25 explicitly affected versions
v1.0.0, v1.0.0-beta.1, v1.0.0-beta.2, v1.0.0-beta.3, v1.0.0-beta.4, v1.0.0-beta.5, v1.0.0-beta.6, v1.0.0-beta.7, v1.1.0, v1.1.1, v1.2.0, v1.3.0, v1.3.1, v1.3.2, v1.3.3, v1.4.0, v1.5.0, v1.6.0, v1.6.1, v1.6.2, v1.6.3, v1.6.4, v1.6.5, v1.6.6, v1.6.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.0.0",
"v1.0.0-beta.1",
"v1.0.0-beta.2",
"v1.0.0-beta.3",
"v1.0.0-beta.4",
"v1.0.0-beta.5",
"v1.0.0-beta.6",
"v1.0.0-beta.7",
"v1.1.0",
"v1.1.1",
"v1.2.0",
"v1.3.0",
"v1.3.1",
"v1.3.2",
"v1.3.3",
"v1.4.0",
"v1.5.0",
"v1.6.0",
"v1.6.1",
"v1.6.2",
"v1.6.3",
"v1.6.4",
"v1.6.5",
"v1.6.6",
"v1.6.7"
]
}