GHSA-v358-rvxr-wffxmedium
Silverstripe XSS Vulnerabilities
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in SilverStripe 2.3.x before 2.3.13 and 2.4.x before 2.4.7 allow remote attackers to inject arbitrary web script or HTML via
- a crafted string to the
AbsoluteLinks BigSummaryContextSummaryEscapeXMLFirstParagraphFirstSentenceInitialLimitCharactersLimitSentencesLimitWordCountLimitWordCountXMLLowerLowerCaseNoHTMLSummaryUpperUpperCase, orURLmethod in a template,
different vectors than CVE-2012-0976.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/framework Packagist
Ecosystem versions
From 2.3 before 2.3.13
Fixed in 2.3.13
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.3"
},
{
"fixed": "2.3.13"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}silverstripe/framework Packagist
Ecosystem versions
From 2.4 before 2.4.7
Fixed in 2.4.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.4"
},
{
"fixed": "2.4.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2012-4968
- https://github.com/silverstripe/sapphire/commit/0085876
- https://github.com/silverstripe/silverstripe-framework/commit/0085876495f0f8dda5dc58cb24a8f2220e7baf1e
- https://github.com/silverstripe/silverstripe-framework/commit/15e9e059e5948ccf8f5a36dfcb435ad26ecec334
- https://github.com/silverstripe/silverstripe-framework
- http://doc.silverstripe.org/framework/en/trunk/changelogs/2.3.13
- http://doc.silverstripe.org/framework/en/trunk/changelogs/2.4.7
- http://www.openwall.com/lists/oss-security/2012/04/30/1
- http://www.openwall.com/lists/oss-security/2012/04/30/3