browsershot local file inclusion vulnerability
The advisory, in context
This affects the package spatie/browsershot from 0.0.0. By specifying a URL in the file:// protocol an attacker is able to include arbitrary files in the resultant PDF.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
Earlier releases before 3.40.1
Fixed in 3.40.1
91 explicitly affected versions
0.1.0, 0.1.1, 0.1.2, 0.1.3, 1.0.0, 1.1.0, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.3.0, 1.4.0, 1.5.0, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.9.1, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.1.0, 2.2.0, 2.3.0, 2.4.0, 2.4.1, 2.4.2, 3.0.0, 3.1.0, 3.10.0, 3.11.0, 3.11.1, 3.12.0, 3.13.0, 3.14.0, 3.14.1, 3.15.0, 3.16.0, 3.16.1, 3.17.0, 3.18.0, 3.19.0, 3.2.0, 3.2.1, 3.20.0, 3.20.1, 3.22.0, 3.22.1, 3.23.0, 3.23.1, 3.24.0, 3.25.0, 3.25.1, 3.26.0, 3.26.1, 3.26.2, 3.26.3, 3.27.0, 3.29.0, 3.3.0, 3.3.1, 3.30.0, 3.31.0, 3.31.1, 3.32.0, 3.32.1, 3.32.2, 3.33.0, 3.33.1, 3.34.0, 3.35.0, 3.36.0, 3.37.0, 3.37.1, 3.37.2, 3.38.0, 3.39.0, 3.4.0, 3.40.0, 3.5.0, 3.6.0, 3.7.0, 3.8.0, 3.8.1, 3.9.0
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.40.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1.0",
"0.1.1",
"0.1.2",
"0.1.3",
"1.0.0",
"1.1.0",
"1.2.0",
"1.2.1",
"1.2.2",
"1.2.3",
"1.2.4",
"1.3.0",
"1.4.0",
"1.5.0",
"1.5.1",
"1.5.2",
"1.5.3",
"1.5.4",
"1.6.0",
"1.7.0",
"1.8.0",
"1.9.0",
"1.9.1",
"2.0.0",
"2.0.1",
"2.0.2",
"2.0.3",
"2.1.0",
"2.2.0",
"2.3.0",
"2.4.0",
"2.4.1",
"2.4.2",
"3.0.0",
"3.1.0",
"3.10.0",
"3.11.0",
"3.11.1",
"3.12.0",
"3.13.0",
"3.14.0",
"3.14.1",
"3.15.0",
"3.16.0",
"3.16.1",
"3.17.0",
"3.18.0",
"3.19.0",
"3.2.0",
"3.2.1",
"3.20.0",
"3.20.1",
"3.22.0",
"3.22.1",
"3.23.0",
"3.23.1",
"3.24.0",
"3.25.0",
"3.25.1",
"3.26.0",
"3.26.1",
"3.26.2",
"3.26.3",
"3.27.0",
"3.29.0",
"3.3.0",
"3.3.1",
"3.30.0",
"3.31.0",
"3.31.1",
"3.32.0",
"3.32.1",
"3.32.2",
"3.33.0",
"3.33.1",
"3.34.0",
"3.35.0",
"3.36.0",
"3.37.0",
"3.37.1",
"3.37.2",
"3.38.0",
"3.39.0",
"3.4.0",
"3.40.0",
"3.5.0",
"3.6.0",
"3.7.0",
"3.8.0",
"3.8.1",
"3.9.0"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2020-7790
- https://github.com/spatie/browsershot/issues/441%23issue-735049731
- https://github.com/spatie/browsershot/pull/440
- https://github.com/spatie/browsershot/commit/8d4bcfb1ff609921007f3fc11d80fcdad35598ac
- https://snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-1037064