GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-rv3r-vqjj-8c76high7.1

Cross-site scripting from content entered in the tags and multiselect fields

No CVE assignedCheck your stack

The advisory, in context

Introduction

Cross-site scripting (XSS) is a type of vulnerability that allows to execute any kind of JavaScript code inside the Panel session of the same or other users. In the Panel, a harmful script can for example trigger requests to Kirby's API with the permissions of the victim.

Such vulnerabilities are critical if you might have potential attackers in your group of authenticated Panel users. They can escalate their privileges if they get access to the Panel session of an admin user. Depending on your site, other JavaScript-powered attacks are possible.

Impact

The tags and multiselect fields allow to select tags from an autocompleted list. The tags field also allows to enter new tags or edit existing tags. Kirby already handled escaping of the autocompleted tags, but unfortunately the Panel used HTML rendering for new or edited tags as well as for custom tags from the content file.

This allowed attackers with Panel access to store malicious HTML code in a tag. The browser of the victim who visited the modified page in the Panel will then have rendered this malicious HTML code.

It also allowed self-inflicted XSS attacks in the tags field (meaning that malicious code is executed in the browser of the user who entered it). This could be used in social engineering attacks where a victim is convinced by an attacker to enter malicious code into a tags field.

Visitors without Panel access could only use this attack vector if your site allows changing the content of a tags or multiselect field from a frontend form (for example user self-registration or the creation of pages from a contact or other frontend form). If you validate or sanitize the provided form data, you are already protected against such attacks by external visitors.

You are also not affected by these vulnerabilities if your site doesn't have untrustworthy users with Panel access or a way to modify field values from the frontend or if you don't use the tags or multiselect fields.

Patches

The problems have been patched in Kirby 3.5.8.1, Kirby 3.6.6.1 and Kirby 3.7.4. Please update to one of these or a later version to fix the vulnerabilities.

Note: The fixes for these vulnerabilities have the side effect that values in the tags and multiselect fields that come from dynamic options are displayed with double escaping (e.g. the & character is displayed as &). In the fix for Kirby 3.5, every value in the tags field is displayed with double escaping when dynamic options are enabled, while dynamic options themselves are displayed with triple escaping. We will fix the double/triple escaping issues with a refactoring of the options fields (tags, multiselect, checkboxes, radio, select and toggles) in Kirby 3.8.

Workarounds

We recommend to update to one of the patch releases. If you cannot update immediately, you can work around the issue by disabling the tags and multiselect fields. This can be done by uncommenting these fields from all your blueprints.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

getkirby/cms Packagist
Ecosystem versions

From 3.5.7 before 3.5.8.1

Fixed in 3.5.8.1

3 explicitly affected versions

3.5.7, 3.5.7.1, 3.5.8

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.5.7"
        },
        {
          "fixed": "3.5.8.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "3.5.7",
    "3.5.7.1",
    "3.5.8"
  ]
}
getkirby/cms Packagist
Ecosystem versions

From 3.6.0 before 3.6.6.1

Fixed in 3.6.6.1

17 explicitly affected versions

3.6.0, 3.6.1, 3.6.1.1, 3.6.2, 3.6.2-rc.1, 3.6.2-rc.2, 3.6.2-rc.3, 3.6.3, 3.6.3-rc.1, 3.6.3-rc.2, 3.6.3.1, 3.6.4, 3.6.4-rc.1, 3.6.5, 3.6.5-rc.1, 3.6.6, 3.6.6-rc.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.6.0"
        },
        {
          "fixed": "3.6.6.1"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "3.6.0",
    "3.6.1",
    "3.6.1.1",
    "3.6.2",
    "3.6.2-rc.1",
    "3.6.2-rc.2",
    "3.6.2-rc.3",
    "3.6.3",
    "3.6.3-rc.1",
    "3.6.3-rc.2",
    "3.6.3.1",
    "3.6.4",
    "3.6.4-rc.1",
    "3.6.5",
    "3.6.5-rc.1",
    "3.6.6",
    "3.6.6-rc.1"
  ]
}
getkirby/cms Packagist
Ecosystem versions

From 3.7.0 before 3.7.4

Fixed in 3.7.4

11 explicitly affected versions

3.7.0, 3.7.0.1, 3.7.0.2, 3.7.1, 3.7.1-rc.1, 3.7.2, 3.7.2-rc.1, 3.7.2.1, 3.7.3, 3.7.3-rc.1, 3.7.4-rc.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "3.7.0"
        },
        {
          "fixed": "3.7.4"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "3.7.0",
    "3.7.0.1",
    "3.7.0.2",
    "3.7.1",
    "3.7.1-rc.1",
    "3.7.2",
    "3.7.2-rc.1",
    "3.7.2.1",
    "3.7.3",
    "3.7.3-rc.1",
    "3.7.4-rc.1"
  ]
}

References