Blind SQL Injection via GridFieldSortableHeader
The advisory, in context
Gridfield state is vulnerable to SQL injections. The vast majority of Gridfields in Silverstripe CMS are affected by this vulnerability.
An attacker with CMS access could execute an arbitrary SQL statement by adding an SQL payload in some parts of the GridField state.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 4.0.0 before 4.10.11
Fixed in 4.10.11
85 explicitly affected versions
4.0.0, 4.0.1, 4.0.1-rc1, 4.0.2, 4.0.3, 4.0.4, 4.0.5, 4.0.6, 4.0.7, 4.1.0, 4.1.0-rc1, 4.1.0-rc2, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.10.0, 4.10.0-beta1, 4.10.0-rc1, 4.10.1, 4.10.10, 4.10.2, 4.10.3, 4.10.4, 4.10.5, 4.10.6, 4.10.7, 4.10.8, 4.10.9, 4.2.0, 4.2.0-beta1, 4.2.1, 4.2.2, 4.2.3, 4.2.4, 4.2.5, 4.3.0, 4.3.0-rc1, 4.3.1, 4.3.2, 4.3.3, 4.3.4, 4.3.5, 4.4.0, 4.4.0-rc1, 4.4.1, 4.4.2, 4.4.3, 4.4.4, 4.4.5, 4.4.6, 4.4.7, 4.5.0, 4.5.0-alpha1, 4.5.0-rc1, 4.5.0-rc2, 4.5.1, 4.5.2, 4.5.3, 4.5.4, 4.6.0, 4.6.0-beta1, 4.6.0-rc1, 4.6.1, 4.6.2, 4.7.0, 4.7.0-beta1, 4.7.0-rc1, 4.7.1, 4.7.2, 4.7.3, 4.7.4, 4.8.0, 4.8.0-beta1, 4.8.0-rc1, 4.8.1, 4.9.0, 4.9.0-alpha1, 4.9.0-beta1, 4.9.0-rc1, 4.9.1, 4.9.2, 4.9.3, 4.9.4
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0"
},
{
"fixed": "4.10.11"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.1",
"4.0.1-rc1",
"4.0.2",
"4.0.3",
"4.0.4",
"4.0.5",
"4.0.6",
"4.0.7",
"4.1.0",
"4.1.0-rc1",
"4.1.0-rc2",
"4.1.1",
"4.1.2",
"4.1.3",
"4.1.4",
"4.1.5",
"4.10.0",
"4.10.0-beta1",
"4.10.0-rc1",
"4.10.1",
"4.10.10",
"4.10.2",
"4.10.3",
"4.10.4",
"4.10.5",
"4.10.6",
"4.10.7",
"4.10.8",
"4.10.9",
"4.2.0",
"4.2.0-beta1",
"4.2.1",
"4.2.2",
"4.2.3",
"4.2.4",
"4.2.5",
"4.3.0",
"4.3.0-rc1",
"4.3.1",
"4.3.2",
"4.3.3",
"4.3.4",
"4.3.5",
"4.4.0",
"4.4.0-rc1",
"4.4.1",
"4.4.2",
"4.4.3",
"4.4.4",
"4.4.5",
"4.4.6",
"4.4.7",
"4.5.0",
"4.5.0-alpha1",
"4.5.0-rc1",
"4.5.0-rc2",
"4.5.1",
"4.5.2",
"4.5.3",
"4.5.4",
"4.6.0",
"4.6.0-beta1",
"4.6.0-rc1",
"4.6.1",
"4.6.2",
"4.7.0",
"4.7.0-beta1",
"4.7.0-rc1",
"4.7.1",
"4.7.2",
"4.7.3",
"4.7.4",
"4.8.0",
"4.8.0-beta1",
"4.8.0-rc1",
"4.8.1",
"4.9.0",
"4.9.0-alpha1",
"4.9.0-beta1",
"4.9.0-rc1",
"4.9.1",
"4.9.2",
"4.9.3",
"4.9.4"
]
}From 4.11.0 before 4.11.14
Fixed in 4.11.14
14 explicitly affected versions
4.11.0, 4.11.1, 4.11.10, 4.11.11, 4.11.12, 4.11.13, 4.11.2, 4.11.3, 4.11.4, 4.11.5, 4.11.6, 4.11.7, 4.11.8, 4.11.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.11.0"
},
{
"fixed": "4.11.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.11.0",
"4.11.1",
"4.11.10",
"4.11.11",
"4.11.12",
"4.11.13",
"4.11.2",
"4.11.3",
"4.11.4",
"4.11.5",
"4.11.6",
"4.11.7",
"4.11.8",
"4.11.9"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2022-38148
- https://forum.silverstripe.org/c/releases
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/CVE-2022-38148.yaml
- https://www.silverstripe.org/blog/tag/release
- https://www.silverstripe.org/download/security-releases
- https://www.silverstripe.org/download/security-releases/CVE-2022-38148