GHSA-rq7f-j68f-mqh3medium6.3
PHP Server Monitor vulnerable to Cross-site Scripting
The advisory, in context
PHP Server Monitor, version 3.2.0, is vulnerable to an XSS via the /phpservermon-3.2.0/vendor/phpmailer/phpmailer/test_script/index.php page in all visible parameters. An attacker could create a specially crafted URL, send it to a victim and retrieve their session details.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
phpservermon/phpservermon Packagist
Ecosystem versions
Earlier releases before 3.3.0
Fixed in 3.3.0
6 explicitly affected versions
v3.1.0, v3.1.1, v3.2.0, v3.2.0-rc1, v3.2.1, v3.2.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.3.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v3.1.0",
"v3.1.1",
"v3.2.0",
"v3.2.0-rc1",
"v3.2.1",
"v3.2.2"
]
}