GHSA-rq6q-hjvh-5mwhcritical
Flow Swift Mailer package Remote code execution
No CVE assignedCheck your stack
The advisory, in context
A remote code execution vulnerability has been found in the Swift Mailer library (swiftmailer/swiftmailer) recently. See this advisory for details. If you are not using the default mail() transport, this particular problem does not affect you. Upgrading is of course still recommended!
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
neos/swiftmailer Packagist
Ecosystem versions
Earlier releases before 5.4.5
Fixed in 5.4.5
6 explicitly affected versions
4.1.5, 5.0.3, 5.2.2, 5.3.1, 5.4.1, 5.4.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.4.5"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.1.5",
"5.0.3",
"5.2.2",
"5.3.1",
"5.4.1",
"5.4.2"
]
}