GHSA-rmcp-9fhq-58pvmedium5.3
Improper permissions handling in MediaWiki AbuseFilter
The advisory, in context
An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
mediawiki/abuse-filter Packagist
Ecosystem versions
Earlier releases before 1.39.9
Fixed in 1.39.9
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.39.9"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}mediawiki/abuse-filter Packagist
Ecosystem versions
From 1.40.0 before 1.41.3
Fixed in 1.41.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.40.0"
},
{
"fixed": "1.41.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}mediawiki/abuse-filter Packagist
Ecosystem versions
From 1.42.0 before 1.42.2
Fixed in 1.42.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.42.0"
},
{
"fixed": "1.42.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}