GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-rj29-j2g4-77q8low2.6

[TagAwareCipher] - Decryption Failure (Regex Match)

Check your stack

The advisory, in context

Impact

Vulnerability in SecureProps involves a regex failing to detect tags during decryption of encrypted data.

This occurs when the encrypted data has been encoded with NullEncoder and passed to TagAwareCipher, and contains special characters such as \n. As a result, the decryption process is skipped since the tags are not detected. This causes the encrypted data to be returned in plain format.

The vulnerability affects users who implement TagAwareCipher with any base cipher that has NullEncoder (not default).

Patches

The patch for the issue has been released. Users are advised to update to version 1.2.2.

Workarounds

The main recommendation is to update to the latest version as there are no breaking changes.

If that's not possible, you can use the default Base64Encoder with the base cipher decorated with TagAwareCipher to prevent special characters in the encrypted string from interfering with regex tag detection logic.

This workaround is safe but may involve double encoding since TagAwareCipher uses Base64Encoder by default.

References

Reported issue: https://github.com/IlicMiljan/Secure-Props/issues/20 Pull request resolving bug: https://github.com/IlicMiljan/Secure-Props/pull/21

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 1.2.0 before 1.2.2

Fixed in 1.2.2

2 explicitly affected versions

v1.2.0, v1.2.1

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "1.2.0"
        },
        {
          "fixed": "1.2.2"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "v1.2.0",
    "v1.2.1"
  ]
}

References