GHSA-rh3m-pr36-xh2fcritical9.8
kelvinmo simplexrd vulnerable to Improper Restriction of XML External Entity Reference
The advisory, in context
A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. This vulnerability affects unknown code of the file simplexrd/simplexrd.class.php. The manipulation leads to xml external entity reference. Upgrading to version 3.1.1 is able to address this issue. The name of the patch is 4c9f2e028523ed705b555eca2c18c64e71f1a35d. It is recommended to upgrade the affected component. VDB-217630 is the identifier assigned to this vulnerability.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
kelvinmo/simplexrd Packagist
Ecosystem versions
Earlier releases before 3.1.1
Fixed in 3.1.1
3 explicitly affected versions
v2.2, v3.0, v3.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.2",
"v3.0",
"v3.1"
]
}