GHSA-rh3c-7wqx-6w95medium6.1
zend-diactoros Cross-site Scripting (XSS)
The advisory, in context
Zend/Diactoros/Uri::filterPath in zend-diactoros before 1.0.4 does not properly sanitize path input, which allows remote attackers to perform cross-site scripting (XSS) or open redirect attacks.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
zendframework/zend-diactoros Packagist
Ecosystem versions
From 1.0.0 before 1.0.4
Fixed in 1.0.4
4 explicitly affected versions
1.0.0, 1.0.1, 1.0.2, 1.0.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.0.0"
},
{
"fixed": "1.0.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0.0",
"1.0.1",
"1.0.2",
"1.0.3"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2015-3257
- https://framework.zend.com/security/advisory/ZF2015-05
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-diactoros/CVE-2015-3257.yaml
- https://github.com/zendframework/zend-diactoros
- http://www.securityfocus.com/bid/75466