GHSA-rgf6-9q7g-55qglow
Typo3 Function Menu API XSS Vulnerability
The advisory, in context
Cross-site scripting (XSS) vulnerability in the function menu API in TYPO3 4.5.x before 4.5.21, 4.6.x before 4.6.14, and 4.7.x before 4.7.6 allows remote authenticated backend users to inject arbitrary web script or HTML via unspecified vectors.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 4.5.0 before 4.5.21
Fixed in 4.5.21
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0"
},
{
"fixed": "4.5.21"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.6.0 before 4.6.14
Fixed in 4.6.14
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.6.0"
},
{
"fixed": "4.6.14"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.7.0 before 4.7.6
Fixed in 4.7.6
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.6"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}