GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-rg7p-wmgj-f374medium6.1

Magento stored Cross-Site Scripting (XSS) vulnerability

Check your stack

The advisory, in context

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 2.3.0 before 2.3.7-p4

Fixed in 2.3.7-p4

17 explicitly affected versions

2.3.0, 2.3.1, 2.3.2, 2.3.2-p2, 2.3.3, 2.3.3-p1, 2.3.4, 2.3.4-p2, 2.3.5, 2.3.5-p1, 2.3.5-p2, 2.3.6, 2.3.6-p1, 2.3.7, 2.3.7-p1, 2.3.7-p2, 2.3.7-p3

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.3.0"
        },
        {
          "fixed": "2.3.7-p4"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.3.0",
    "2.3.1",
    "2.3.2",
    "2.3.2-p2",
    "2.3.3",
    "2.3.3-p1",
    "2.3.4",
    "2.3.4-p2",
    "2.3.5",
    "2.3.5-p1",
    "2.3.5-p2",
    "2.3.6",
    "2.3.6-p1",
    "2.3.7",
    "2.3.7-p1",
    "2.3.7-p2",
    "2.3.7-p3"
  ]
}
Ecosystem versions

From 2.4.4 before 2.4.5

Fixed in 2.4.5

14 explicitly affected versions

2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13, 2.4.4-p2, 2.4.4-p3, 2.4.4-p4, 2.4.4-p5, 2.4.4-p6, 2.4.4-p7, 2.4.4-p8, 2.4.4-p9

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.4.4"
        },
        {
          "fixed": "2.4.5"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.4.4",
    "2.4.4-p1",
    "2.4.4-p10",
    "2.4.4-p11",
    "2.4.4-p12",
    "2.4.4-p13",
    "2.4.4-p2",
    "2.4.4-p3",
    "2.4.4-p4",
    "2.4.4-p5",
    "2.4.4-p6",
    "2.4.4-p7",
    "2.4.4-p8",
    "2.4.4-p9"
  ]
}
Ecosystem versions

From 2.4.0 before 2.4.3-p3

Fixed in 2.4.3-p3

10 explicitly affected versions

2.4.0, 2.4.0-p1, 2.4.1, 2.4.1-p1, 2.4.2, 2.4.2-p1, 2.4.2-p2, 2.4.3, 2.4.3-p1, 2.4.3-p2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.4.0"
        },
        {
          "fixed": "2.4.3-p3"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.4.0",
    "2.4.0-p1",
    "2.4.1",
    "2.4.1-p1",
    "2.4.2",
    "2.4.2-p1",
    "2.4.2-p2",
    "2.4.3",
    "2.4.3-p1",
    "2.4.3-p2"
  ]
}

References