GHSA-rfh8-25h9-mhgfmedium6.1
Cross-site Scripting in YII2-CMS
The advisory, in context
YII2-CMS v1.0 has XSS in protected\core\modules\home\models\Contact.php via a name field to /contact.html.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
yii2mod/yii2-cms Packagist
Ecosystem versions
Earlier releases before 1.9.2
Fixed in 1.9.2
19 explicitly affected versions
1.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.1, 1.2, 1.3, 1.4, 1.4.1, 1.5, 1.5.1, 1.6, 1.7, 1.8, 1.8.1, 1.9, 1.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"1.0",
"1.0.1",
"1.0.2",
"1.0.3",
"1.0.4",
"1.0.5",
"1.1",
"1.2",
"1.3",
"1.4",
"1.4.1",
"1.5",
"1.5.1",
"1.6",
"1.7",
"1.8",
"1.8.1",
"1.9",
"1.9.1"
]
}