GHSA-rc94-7v55-wmg6high8.8
Subrion CMS CSRF Vulnerability
The advisory, in context
There are CSRF vulnerabilities in Subrion CMS 4.1.x through 4.1.5, and before 4.2.0, because of a logic error. Although there is functionality to detect CSRF, it is called too late in the ia.core.php code, allowing (for example) an attack against the query parameter to panel/database.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
intelliants/subrion Packagist
Ecosystem versions
From 4.1 before 4.2.0
Fixed in 4.2.0
6 explicitly affected versions
v4.1.0, v4.1.1, v4.1.2, v4.1.3, v4.1.4, v4.1.5
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.1"
},
{
"fixed": "4.2.0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.1.0",
"v4.1.1",
"v4.1.2",
"v4.1.3",
"v4.1.4",
"v4.1.5"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2017-15063
- https://github.com/intelliants/subrion/issues/547
- https://github.com/intelliants/subrion/issues/570
- https://github.com/intelliants/subrion/commit/5fdf03af1a7d89c3692faa155e17457153020dca
- https://github.com/intelliants/subrion/commit/65fb937a588d730e57da0c2c5ca3bc4b9c2b5628