Silverstripe XSS vulnerability via VirtualPage
The advisory, in context
A cross-site scripting vulnerability has been discovered in the VirtualPage class.
This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the textfields of a page which a VirtualPage refers to.
This has been resolved by ensuring that VirtualPage safely escapes all field content.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 3.1.0 before 3.1.10
Fixed in 3.1.10
22 explicitly affected versions
3.1.0, 3.1.1, 3.1.10-rc1, 3.1.10-rc2, 3.1.2, 3.1.2-rc1, 3.1.3, 3.1.3-rc1, 3.1.3-rc2, 3.1.4, 3.1.4-rc1, 3.1.5, 3.1.5-rc1, 3.1.6, 3.1.6-rc1, 3.1.6-rc2, 3.1.6-rc3, 3.1.7, 3.1.7-rc1, 3.1.8, 3.1.9, 3.1.9-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "3.1.0"
},
{
"fixed": "3.1.10"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.1.0",
"3.1.1",
"3.1.10-rc1",
"3.1.10-rc2",
"3.1.2",
"3.1.2-rc1",
"3.1.3",
"3.1.3-rc1",
"3.1.3-rc2",
"3.1.4",
"3.1.4-rc1",
"3.1.5",
"3.1.5-rc1",
"3.1.6",
"3.1.6-rc1",
"3.1.6-rc2",
"3.1.6-rc3",
"3.1.7",
"3.1.7-rc1",
"3.1.8",
"3.1.9",
"3.1.9-rc1"
]
}