SimpleSAMLphp SAML2 spoof SAML responses
The advisory, in context
The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
From 1.10 before 1.10.3
Fixed in 1.10.3
3 explicitly affected versions
v1.10, v1.10.1, v1.10.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.10"
},
{
"fixed": "1.10.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v1.10",
"v1.10.1",
"v1.10.2"
]
}Earlier releases before 1.8.1
Fixed in 1.8.1
34 explicitly affected versions
v0.1.0, v0.1.0-alpha, v0.3.0, v0.4.0, v0.4.1, v0.4.2, v0.5.0, v0.6.0, v0.6.1, v0.6.2, v0.6.3, v0.6.4, v0.7.0, v0.7.1, v0.8.0, v0.8.1, v1.0.0, v1.1.0, v1.2.0, v1.3.0, v1.3.1, v1.3.2, v1.4.0, v1.5.0, v1.5.1, v1.5.2, v1.5.3, v1.5.4, v1.6.0, v1.6.1, v1.7.0, v1.7.1, v1.7.2, v1.8
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v0.1.0",
"v0.1.0-alpha",
"v0.3.0",
"v0.4.0",
"v0.4.1",
"v0.4.2",
"v0.5.0",
"v0.6.0",
"v0.6.1",
"v0.6.2",
"v0.6.3",
"v0.6.4",
"v0.7.0",
"v0.7.1",
"v0.8.0",
"v0.8.1",
"v1.0.0",
"v1.1.0",
"v1.2.0",
"v1.3.0",
"v1.3.1",
"v1.3.2",
"v1.4.0",
"v1.5.0",
"v1.5.1",
"v1.5.2",
"v1.5.3",
"v1.5.4",
"v1.6.0",
"v1.6.1",
"v1.7.0",
"v1.7.1",
"v1.7.2",
"v1.8"
]
}From 1.9.0 before 1.9.1
Fixed in 1.9.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "1.9.0"
},
{
"fixed": "1.9.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}From 2.0 before 2.3.3
Fixed in 2.3.3
7 explicitly affected versions
v2.0.0, v2.0.1, v2.1, v2.2, v2.3, v2.3.1, v2.3.2
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "2.0"
},
{
"fixed": "2.3.3"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v2.0.0",
"v2.0.1",
"v2.1",
"v2.2",
"v2.3",
"v2.3.1",
"v2.3.2"
]
}References
- https://nvd.nist.gov/vuln/detail/CVE-2016-9814
- https://github.com/FriendsOfPHP/security-advisories/blob/master/simplesamlphp/saml2/CVE-2016-9814.yaml
- https://github.com/simplesamlphp/simplesamlphp
- https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html
- https://simplesamlphp.org/security/201612-01
- http://www.securityfocus.com/bid/94730