GHSA-r8m7-792j-5jvqlow3.0
TYPO3 Cross-Site Scripting (XSS) vulnerabilities in Content Editing Wizards component
The advisory, in context
Multiple cross-site scripting (XSS) vulnerabilities in Content Editing Wizards in TYPO3 4.5.x before 4.5.32, 4.7.x before 4.7.17, 6.0.x before 6.0.12, 6.1.x before 6.1.7, and the development versions of 6.2 allow remote authenticated users to inject arbitrary web script or HTML via unspecified parameters.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
typo3/cms Packagist
Ecosystem versions
From 4.5.0 before 4.5.32
Fixed in 4.5.32
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.5.0"
},
{
"fixed": "4.5.32"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 4.7.0 before 4.7.17
Fixed in 4.7.17
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.7.0"
},
{
"fixed": "4.7.17"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.0.0 before 6.0.12
Fixed in 6.0.12
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.0.0"
},
{
"fixed": "6.0.12"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}typo3/cms Packagist
Ecosystem versions
From 6.1.0 before 6.1.7
Fixed in 6.1.7
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "6.1.0"
},
{
"fixed": "6.1.7"
}
],
"type": "ECOSYSTEM"
}
],
"versions": []
}References
- https://nvd.nist.gov/vuln/detail/CVE-2013-7074
- https://exchange.xforce.ibmcloud.com/vulnerabilities/89620
- https://github.com/TYPO3/typo3
- http://osvdb.org/100881
- http://seclists.org/oss-sec/2013/q4/473
- http://seclists.org/oss-sec/2013/q4/487
- http://typo3.org/teams/security/security-bulletins/typo3-core/typo3-core-sa-2013-004
- http://www.debian.org/security/2014/dsa-2834
- http://www.securityfocus.com/bid/64245