GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

Check your stack
GHSA-r8hm-w5f7-wj39medium6.1

Cross-site scripting vulnerability in TinyMCE plugins

Impact

A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the image and link plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower.

Source excerpt · OSV

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Affected rangeRecorded fix
Earlier releases before 5.10.0Semantic versions5.10.0

Version evidence: OSV · GHSA-r8hm-w5f7-wj39

View original version evidence (0 explicit versions)
Affected rangeRecorded fix
Earlier releases before 5.10.0Ecosystem versions5.10.0

Version evidence: OSV · GHSA-r8hm-w5f7-wj39

View original version evidence (163 explicit versions)
Affected rangeRecorded fix
Earlier releases before 5.10.0Ecosystem versions5.10.0

Version evidence: OSV · GHSA-r8hm-w5f7-wj39

View original version evidence (172 explicit versions)
Affected rangeRecorded fix
Earlier releases before 3.4.0Ecosystem versions3.4.0

Version evidence: OSV · GHSA-r8hm-w5f7-wj39

View original version evidence (44 explicit versions)

Original source description

Impact

A cross-site scripting (XSS) vulnerability was discovered in the URL processing logic of the image and link plugins. The vulnerability allowed arbitrary JavaScript execution when updating an image or link using a specially crafted URL. This issue only impacted users while editing and the dangerous URLs were stripped in any content extracted from the editor. This impacts all users who are using TinyMCE 5.9.2 or lower.

Patches

This vulnerability has been patched in TinyMCE 5.10.0 by improved sanitization logic when updating URLs in the relevant plugins.

Workarounds

To work around this vulnerability, either:

  • Upgrade to TinyMCE 5.10.0 or higher
  • Disable the image and link plugins

Acknowledgements

Tiny Technologies would like to thank Yakir6 for discovering this vulnerability.

References

https://www.tiny.cloud/docs/release-notes/release-notes510/#securityfixes

For more information

If you have any questions or comments about this advisory:

References