GHSA-r58m-v5pr-jhhqcritical9.6
Cross-site Scripting in kimai/kimai
The advisory, in context
Cross Site Scripting (XSS) vulnerability in kevinpapst kimai2 in /src/Twig/Runtime/MarkdownExtension.php, allows attackers to gain escalated privileges.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
kimai/kimai Packagist
Ecosystem versions
Earlier releases before 1.1
Fixed in 1.1
13 explicitly affected versions
0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.6.1, 0.7, 0.8, 0.8.1, 0.9, 1.0, 1.0.1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"0.1",
"0.2",
"0.3",
"0.4",
"0.5",
"0.6",
"0.6.1",
"0.7",
"0.8",
"0.8.1",
"0.9",
"1.0",
"1.0.1"
]
}