GHSA-r3pr-fh25-wrfcmedium6.5
silverstripe/framework's install.php script discloses sensitive data by pre-populating DB credential forms
No CVE assignedCheck your stack
The advisory, in context
When accessing the install.php script it is possible to extract any pre-configured database or default admin account password by viewing the source of the page, and inspecting the value property of the password fields.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
silverstripe/framework Packagist
Ecosystem versions
From 4.0.0-rc1 before 4.0.1
Fixed in 4.0.1
5 explicitly affected versions
4.0.0, 4.0.0-rc1, 4.0.0-rc2, 4.0.0-rc3, 4.0.1-rc1
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.0.0-rc1"
},
{
"fixed": "4.0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.0",
"4.0.0-rc1",
"4.0.0-rc2",
"4.0.0-rc3",
"4.0.1-rc1"
]
}References
- https://github.com/silverstripe/silverstripe-framework/commit/7a79cd039a96ef54182263d5fbb72addf093b171
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2017-010-1.yaml
- https://github.com/silverstripe/silverstripe-framework
- https://www.silverstripe.org/download/security-releases/ss-2017-010