GHSA-r2wx-46gp-rp3hhigh
Moodle Improper Input Validation
The advisory, in context
Unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php. The referrer URL used by MFA required additional sanitizing, rather than being used directly.
Affected packages
Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.
moodle/moodle Packagist
Ecosystem versions
From 4.3.0 before 4.3.4
Fixed in 4.3.4
4 explicitly affected versions
v4.3.0, v4.3.1, v4.3.2, v4.3.3
View affected-version evidence
{
"ranges": [
{
"events": [
{
"introduced": "4.3.0"
},
{
"fixed": "4.3.4"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"v4.3.0",
"v4.3.1",
"v4.3.2",
"v4.3.3"
]
}