GIVE YOUR AGENT THE EVIDENCE

Set up in your agent.

One prompt to get started. Paste it into your coding agent to connect cve.new through MCP and bring vulnerability context into your workflow.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GIVE YOUR AGENT THE EVIDENCE

Investigate in your agent.

Turn this advisory into a focused investigation. Ask your agent to check your project’s versions, explain the evidence, and suggest a compatible fix.

Your agent needs remote MCP support and access to https://cve.new/mcp.

Read the setup guide

GHSA-qwx8-mxxx-mg96medium6.5

wallabag contains Improper Authorization via export feature

Check your stack

The advisory, in context

Description

The export feature lets a user export a single entry or a set of entries in a given format (e.g. PDF, MOBI, TXT).

For example, https://yourinstance.wallabag.org/export/45.pdf will export the entry with id 45 in PDF format.

Since wallabag 2.0.0-alpha.1, this feature is vulnerable to an insecure direct object reference attack. A logged user can export any single entry without ownership validation.

This is due to a lack of access validation in the downloadEntryAction method.

You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration.

Resolution

A user check is now done in the vulnerable method before sending the exported entry.

The Entry retrieval through a ParamConverter has also been replaced with a call to the EntryRepository in order to prevent any information disclosure through response discrepancy.

Workaround

If you are unable to update to the latest version or if you want to temporarily limit risk of exploitation, you may consider blocking requests to the endpoint /export/*.

E.g. with nginx:

    location /export {
        deny all;
    }

Credits

We would like to thank @bAuh0lz for reporting this issue through huntr.dev.

Reference: https://www.huntr.dev/bounties/3adef66f-fc86-4e6d-a540-2ffa59342ff0/

Affected packages

Start with the recorded fix for your release branch. Check your installed version and test compatibility before upgrading. Fixing this advisory does not rule out other vulnerabilities in the release.

Ecosystem versions

From 2.0.0-alpha.1 before 2.5.3

Fixed in 2.5.3

41 explicitly affected versions

2.0.0, 2.0.0-alpha.1, 2.0.0-alpha.2, 2.0.0-beta.1, 2.0.0-beta.2, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6, 2.0.7, 2.0.8, 2.1.0, 2.1.1, 2.1.2, 2.1.3, 2.1.4, 2.1.5, 2.1.6, 2.1.6.1, 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.7, 2.3.8, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.5.0, 2.5.1, 2.5.2

View affected-version evidence
{
  "ranges": [
    {
      "events": [
        {
          "introduced": "2.0.0-alpha.1"
        },
        {
          "fixed": "2.5.3"
        }
      ],
      "type": "ECOSYSTEM"
    }
  ],
  "versions": [
    "2.0.0",
    "2.0.0-alpha.1",
    "2.0.0-alpha.2",
    "2.0.0-beta.1",
    "2.0.0-beta.2",
    "2.0.1",
    "2.0.2",
    "2.0.3",
    "2.0.4",
    "2.0.5",
    "2.0.6",
    "2.0.7",
    "2.0.8",
    "2.1.0",
    "2.1.1",
    "2.1.2",
    "2.1.3",
    "2.1.4",
    "2.1.5",
    "2.1.6",
    "2.1.6.1",
    "2.2.0",
    "2.2.1",
    "2.2.2",
    "2.2.3",
    "2.3.0",
    "2.3.1",
    "2.3.2",
    "2.3.3",
    "2.3.4",
    "2.3.5",
    "2.3.6",
    "2.3.7",
    "2.3.8",
    "2.4.0",
    "2.4.1",
    "2.4.2",
    "2.4.3",
    "2.5.0",
    "2.5.1",
    "2.5.2"
  ]
}

References